Подключить сканер штрихкода в САМОПИСНУЮ конфигурацию 1С на обычных формах

В список проектов
Название: Подключить сканер штрихкода в САМОПИСНУЮ конфигурацию 1С на обычных формах
Город: Москва
Предполагаемый бюджет: 2 000 руб.
Категория: Периферийные устройства
Конфигурация: Конфигурации 1cv8
Платформа: Платформа 1С v8.3
Сроки: От 1 ч. до 3 ч.
Файл проекта: Скачать
Статус: Выбран исполнитель
Исполнитель:
резюме удалено

О проекте

Есть сканер штрикодов NLS-FM430. Драйверы на компьютер установлены.
Конфигурация 1С предельно простая и состоит всего лишь из одной обработки на обычных формах. В этой обработке есть процедура.
Процедура ВнешнееСобытие(Источник, Событие, Данные)
    // При считывании сканером штрихкода, должно выдаваться сообщение
    Сообщить("Внешнее событие");
    // Или если есть точка останова, на этой строке должен останавливаться отладчик
    А=1;
КонецПроцедуры
ЗАДАЧА: Нужно чтобы отрабатывала процедура ВнешнееСобытие(), при считывании сканером штрихкода
Конфигурация в файле приложенном к тендеру. Также в файле приложенном к тендеру подробные фото сканера.

Конфигурация самописная, никаких обработок "Подключение торгового оборудования" в ней нет.
На некоторых форумах описаны примерные способы решения такой задачи, все они сводятся к тому что в процедуру ПриНачалеРаботыСистемы() нужно вставить что-то наподобие

Процедура ПриНачалеРаботыСистемы()
    
    // Начало работы со сканером
    Попытка
        ПодключитьВнешнююКомпоненту("scanopos.dll", "Сканер");
        Драйвер = Новый("AddIn.Сканер.Scanner");
        Сообщить("Компонента для сканера штрих-кодов загружена!");
    Исключение
        Сообщить ("Невозможно подключить внешнюю компоненту!");
    КонецПопытки;
    
    Попытка
        ВерсияИзДрайвера = Драйвер.ПолучитьНомерВерсии();
    Исключение
        Сообщить ("Невозможно определить версию драйвера!");
    КонецПопытки;
    
    Если Драйвер.Подсоединить("Сканер штрихкода") <> 0 Тогда
        Сообщить ("Ошибка (1) при подключении устройства!");
    КонецЕсли;    
    
    //сканер настроить - префикса нет, суффикс - CR
    
    Драйвер.БитДанных  = 8;
    Драйвер.Порт       = 1;
    Драйвер.Скорость   = 9600;
    Драйвер.СтопБит    = 1;
    Драйвер.СтопСимвол = 13; //CR - carriage return
    
    Драйвер.ИмяСобытия = "ПолученШтрихкод";
    
    Драйвер.УстройствоВключено = 1;
    Драйвер.ПосылкаДанных      = 1;
    Драйвер.ОчиститьВход();
    Драйвер.ОчиститьВыход();
    Сообщить("Сканер подключен и готов к работе!");
    //Драйвер.ТестУстройства();
    Если Драйвер.УстройствоВключено <> 1 Тогда
        //Отключить();
        
        Драйвер.УстройствоВключено = 0;
        Драйвер.Освободить();
        Драйвер.Отсоединить();
        Сообщить ("Ошибка (2) при подключении устройства!");
    КонецЕсли;    
    // Начало работы со сканером
    
КонецПроцедуры

Данный конкретный текст не работает, нужно что-то изменить. Возможно именно в этом и состоит задача.
Для конкретного исполнителя будет возможность подключиться и помощь сетевого администратора, если понадобиться.